Rétrosignalisation S88

Pour poser les questions concernant la mise en oeuvre du XIS88 et du FIS88

Re: Rétrosignalisation S88

Messagepar jpp38 » 01 Mai 2018, 18:54

C'est bien l'USB-UART de chez Mikroelektronika (celle que j'ai montrée sur la doc) , que tu utilises? Pas une autre.

JP
jpp38
 
Messages: 11096
Inscrit le: 31 Mars 2009, 10:15
Localisation: Grenoble (Isère / Rhône Alpes)

Re: Rétrosignalisation S88

Messagepar Didier L » 01 Mai 2018, 19:51

Absolument.
Selectronic ne le tenait plus en stock : le leur ai envoyé la photo que tu avais mise dans la description du XIS88, et ils en ont approvisionné une spécialement (au prix de l'année dernière, soi-dit en passant).

D'ailleurs, j'imagine que la carte ne fonctionnerait pas du tout, quelque-soit le fichier HEX injecté dans le PIC, si quelque chose n'était pas conforme.
Pièces jointes
XIS88_Photo.jpg
Didier L
 
Messages: 36
Inscrit le: 29 Octobre 2017, 20:07

Re: Rétrosignalisation S88

Messagepar jpp38 » 02 Mai 2018, 07:18

Bonjour,

Est-ce que tu arrives à communiquer avec un émulateur de terminal, comme expliqué en section 7 (Annexe 3) de ce même document ?: commande dccdcc.

JP
jpp38
 
Messages: 11096
Inscrit le: 31 Mars 2009, 10:15
Localisation: Grenoble (Isère / Rhône Alpes)

Re: Rétrosignalisation S88

Messagepar Didier L » 02 Mai 2018, 19:53

Bonsoir Jean-Pierre.

Déjà, je te remercie de ton aide (dont de plus je vois qu'elle est matinale !).

Oui, je communique sans problème : la version s'affiche (GenLi v3.A me semble-t'il, de toutes façons par sécurité j'ai utilisé le HEX que tu m'as fourni), suivie de l'option a) (adresse Xpressnet), de l'option b) (adresse Feedback) et de l'option c) (sortie).
J'ai d'ailleurs modifié l'adresse Xpressnet plusieurs fois (en la mettant une première fois à 28, puis à 30, et en vérifiant chaque fois que la nouvelle adresse était bien prise en compte) : pas de changement (pas de serveur trouvé).
Je suis finalement revenu à l'adresse 29, ce qui bien sûr n'a pas permis non plus le démarrage du serveur.

Je suis désolé de te soumettre un problème jamais rencontré, mais tu es visiblement le seul qui puisse trouver la solution (s'il y en a une ....).

Bien cordialement.

Didier.
Didier L
 
Messages: 36
Inscrit le: 29 Octobre 2017, 20:07

Re: Rétrosignalisation S88

Messagepar jpp38 » 03 Mai 2018, 05:12

Bonjour,

Tu m'as que tu utilisais la LI101F. Tu l'as toujours?
Est-ce que CDM-Rail se connecte correctement via la LI-101F, avec cette même centrale?

JP
jpp38
 
Messages: 11096
Inscrit le: 31 Mars 2009, 10:15
Localisation: Grenoble (Isère / Rhône Alpes)

Re: Rétrosignalisation S88

Messagepar Didier L » 03 Mai 2018, 19:23

Bonjour Jean-Pierre.

De plus en plus matinal !
Oui, aucun problème pour me connecter via la Li-101F.
Au début de l'utilisation du XIS88, j'avais (par méconnaissance) complètement foiré la connexion de mes détecteurs : ceux-ci étaient en effet munis d'une led de contrôle, alimentée en 12 V, et j'avais raccordé les sorties de cette led au module de rétro = je mélangeais alors le 5 V en provenance du XIS88 et le 12 V en provenance des détecteurs.
Suite aux conseils de Chris, les détecteurs sont maintenant correctement raccordés (à la sortie d'un optocoupleur H11AA1).
Mais cette (très) mauvaise manip initiale ne peut-elle pas avoir bousillé un composant du XIS88 (sachant que je relevais alors une tension de 8 V aux bornes des entrées du module rétro dans le cas d'un canton libre, et non pas 0 V) ? Car, en résumé, le XIS88 fonctionne tant que je ne lui adjoins pas la fonction rétro (puisqu'il fonctionne avec le HEX qui ne gère pas la rétro) : on a bien l'impression que c'est la rétro qui fout le bazar.
Je viens par exemple de changer le 74HC245, sans amélioration malheureusement (dans mon cas, c'est très précisément un 74HC245AP(F)).
Est-ce que cela pourrait être intéressant de changer également les 6N136 et le MAX 485 ? Ou d'autres composants peuvent-ils avoir été abîmés ?

Bien cordialement.
Didier L
 
Messages: 36
Inscrit le: 29 Octobre 2017, 20:07

Re: Rétrosignalisation S88

Messagepar jpp38 » 04 Mai 2018, 06:42

Bonjour,

En effet, ça ressemble à un problème du côté de la transmission Xpressnet.
Est-ce que tu vois la LED clignoter?

Vérifie bien tes soudures, aussi, et un éventuel "micro_pont" entre deux traces. Je pense que tu l'as déjà fait, mais j'ai déjà vu des cas où ça échappait à l'inspection.

JP
jpp38
 
Messages: 11096
Inscrit le: 31 Mars 2009, 10:15
Localisation: Grenoble (Isère / Rhône Alpes)

Re: Rétrosignalisation S88

Messagepar Didier L » 04 Mai 2018, 20:41

Bonsoir Jean-Pierre.

J'ai en effet déjà vu clignoter la led, mais je m'étais justement fait la remarque qu'elle clignotait rarement, et très faiblement : il faut bien la regarder pour s'en apercevoir.
J'avais en effet déjà fait les contrôles de continuité des pistes, et des éventuels ponts, et je viens de le refaire : je n'ai qu'un ohm-mètre, mais tout est apparemment ok avec celui-ci.

Ce qui me ramène à une question plus générale : compte-tenu du fait que le problème que je rencontre est inédit et apparemment vicieux, je crains que même avec ton aide (précieuse, et très autorisée), nous n'arrivions pas à le résoudre, et du coup je vais probablement être dans l'obligation d'investir dans du matériel tout fait (même si j'ai déjà évoqué le fait que cela ne me souriait guère compte-tenu du budget à précoir).
Malgré tout, et sachant que je suis en Lenz, quel matériel de rétro me conseillerais tu le cas échéant ?

Bien cordialement.
Didier L
 
Messages: 36
Inscrit le: 29 Octobre 2017, 20:07

Re: Rétrosignalisation S88

Messagepar Didier L » 04 Mai 2018, 21:45

Re-bonsoir Jean-Pierre.

Y a-t'il des contrôles que je puisse faire, je pense par exemple à la fiche que tu as fait pour vérifier la carte 16 entrées de Paco (et dont je me suis servi pour vérifier l'adaptation S88N qu'en a fait Chris) : y aurait-il, sur ce même principe, des contrôles que je pourrais faire sur le XIS88 afin d'éliminer certaines pistes de recherche ?

Bien cordialement.
Didier L
 
Messages: 36
Inscrit le: 29 Octobre 2017, 20:07

Re: Rétrosignalisation S88

Messagepar jpp38 » 05 Mai 2018, 13:26

Bonjour,

Je te donne mon adresse en MP.
Envoie-le moi pour que je regarde.

JP
jpp38
 
Messages: 11096
Inscrit le: 31 Mars 2009, 10:15
Localisation: Grenoble (Isère / Rhône Alpes)

PrécédentSuivant

Retourner vers Support sur XIS88, FIS88

Qui est en ligne ?

Utilisateurs parcourant actuellement ce forum : Aucun utilisateur inscrit et 1 invité